Results 1 to 4 of 4

Thread: Compile NeoHookeanPI in VS2017

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Mar 2017
    Posts
    11

    Default Compile NeoHookeanPI in VS2017

    I'm posting this just in case someone is having issues with compiling the NeoHookeanPI plugin.

    Here are the steps that I needed to take to be able to compile the x64 Release version of the NeoHookeanPI example plugin from just the source files with VS2017 and FEBio v2.6.4.

    1. Download and Install FEBio SDK, NeoHookeanPI plugin, VS2013 Community and VS2017 Community
    2. In VS2017 do File > New > Project ; Visual C++ > Win32 > Win32 Project > (set name and location) > OK ; Next > DLL > Empty project > Finish
    3. Add source files from NeoHookeanPI\source
    4. Right-click the project > Properties; Change the following:
      • General:
        - Platform Toolset: Visual Studio 2013 (v120)
      • VC++ Directories:
        - Include Directories: C:\Program Files\febio-2.6.4\sdk\include;...
        - Library Directories: C:\Program Files\febio-2.6.4\sdk\lib\VS2013;...
      • C/C++ > Preprecessor:
        - Preprecessor Definitions: WIN32;...
      • Linker > Input:
        - Additional Dependencies: fecore.lib;febiomech.lib;...


    To test for successful compilation:
    • Open "C:\Program Files\febio-2.6.4\bin\febio.xml"
    • Below the linear_solver line add:
      <import>Path\To\New\Plugin\x64\Release\PluginName. dll</import>
    • In NeoHookeanPI\Example run FEBio on co01.feb

  2. #2

    Default Cannot Build the NeoHookeanPI Project in Visual Studio

    Hi, I've followed all your steps in VS2015 with febio2.64, but when I tried to build the project, it shows that the two header files cannot be accessed.
    Webp.net-resizeimage.png
    I've checked those two header files are in the file as suggested. I also try the VS2017 community and changing "/" to "" and so on but all of them don't work.
    What is the problem for not being able to access those two header files?

  3. #3
    Join Date
    Mar 2017
    Posts
    11

    Default

    I'm not exactly sure but maybe you didn't update the Include/Library directories to use your current version of the SDK (in my example is version 2.6.4)?

  4. #4

    Default

    Quote Originally Posted by MiguelA View Post
    I'm not exactly sure but maybe you didn't update the Include/Library directories to use your current version of the SDK (in my example is version 2.6.4)?
    I've already tried febio2.64 and 2.70, but both of them don't work. Here is my screenshot.
    libtest.png
    Moreover, when I use the VS2017community I cannot find the kind of WIN32 empty .dll as you suggest, my screenshot looks like this
    VS22.png
    VS1.png
    which project should I choose then? I can find those option as you posted when I use my old version of VS2015. I think maybe your version of visual studio is not really the VS2017 community?
    Is there a tutorial that I don't need to use visual studio if I'm using windows?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •