Active contraction in Transversely Isotropic Mooney-Rivlin
issueid=759 12-15-2016 11:17 AM
Junior Member
Active contraction in Transversely Isotropic Mooney-Rivlin

Hello,

I am trying to use the active contraction in the Transversely Isotropic Mooney-Rivlin model on a Mac. I tried running the test suite model (fi01.feb) in FEBio versions 2.4 and 2.5, but nothing happens in the model (No force acting on system). When I run the model using v 2.3, the model does what it's supposed to do (the bar contracts). My colleague ran the test suite model on a Linux using v. 2.4.3, so this seems to be a Mac issue affecting v.2.4 and 2.5 releases.

Thank you,
Kyoko
Issue Details
Issue Number 759
Project FEBio
Category Unknown
Status Not a Bug
Priority Unknown
Affected Version Unknown
Fixed Version (none)
Users able to reproduce bug 0
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)




06-26-2017 09:27 AM
Moderator
Hi Kyoko,

I haven't been able to reproduce this bug on 2.4.2, 2.5.0 or 2.6.3 on the Mac. All these versions produce a contraction in this model (fi01.feb). As far as our records show, fi01.feb was last modified on August 14, 2015, so I am guessing that you are using the latest version.

Would you be able to post (or email me) another test problem that seems to fail?

Best,

Gerard

06-26-2017 03:42 PM
Moderator
Hi Kyoko,

Thanks for emailing me the file you used. That file is an older version, which has one difference against the current file in the test suite:

The old file uses
<active_contraction lc="1">

The latest test suite file uses
<active_contraction>
<ascl lc="1">1</ascl>

If you make that change to your file it should run properly (please let me know otherwise).

Best,

Gerard

+ Reply