'preview.exe has stopped working'
issueid=541 05-16-2012 06:07 PM
Junior Member
'preview.exe has stopped working'
Preview keep crashing during creation / unable to open prv files once FEBio applied (Windows 7)

I just started using FEBio on Windows 7 with long term goal for my PhD thesis, but it just keeps crashing telling me 'Preview.exe has stopped working'.

That happens more and more frequently during geometry creation. When it does, I cannot even reopen the saved file nor the backup file I made.

In the rare occasion when I complete a geometry and succeed in running all the way through to postview, but did close (and save) the file in preview, I cannot reopen the prv file anymore, either. Preview will open, but then immediately shows 'has stopped working'.

I reinstalled the program, but it didnt make a difference. Now, is this something you can fix or is the problem somewhere hidden here?

Cheers for help
Issue Details
Issue Number 541
Project PreView
Category Compatibility
Status Awaiting Feedback
Priority 5 - Medium
Affected Version Unknown
Fixed Version (none)
Users able to reproduce bug 0
Users unable to reproduce bug 0
Assigned Users maas
Tags (none)

05-17-2012 10:28 AM
Hi Wenx,

Is there a set of repeatable steps that lead to the crash, or does the crash occur randomly? If the steps are repeatable, please list them. Is this the 32 bit or 64 bit version of PreView? Could you attach the prv file that created a successful run but can no longer be opened?



05-29-2017 01:55 AM
Junior Member
I am getting a similar problem to this running Preview on 64-bit Windows 10.
I have tried the following versions:
1.20.3 (32 Bit)
All of them crash immediately on startup ('preview.exe has stopped working') regardless of whether I am attempting to open an existing PRV file or create a new one.
Unlike the problem reported above I can't even begin to create or modify the geometry.
The Preview GUI does load with the default grid on the purple background but I can't click on anything before the crash happens. When attempting to open an existing PRV file the model doesn't appear on-screen in the graphics area before the crash (only the empty grid appears).

Postview (1.10.2, 64 bit) is also displaying similar behaviour, but not consistently (i.e. when attempting to open an xplt file or run the postview executable the startup crash does not occur every time, perhaps between 20-40% of the time? Even with repeated attempts on the same file). When postview crashes in this way the GUI still loads but the main graphics view area is black.

Both Preview and Postview have worked fine on this system in the past. Perhaps installing/updating another program has created some kind of dependency problem. Please let me know if you have any suggestions.


05-30-2017 11:03 AM
Lead Code Developer
Hi Liam,

Did you recently upgrade your graphics card driver? I ask because I had the same problem and it turns out it was the graphics driver. When I rolled back to a previous driver, the problem was gone. If you didn't update the graphics driver, perhaps try updating it.

If it's not a driver issue, I'm not sure what else it could be. We are close to releasing a new version of PostView (version 2.0). which uses an entirely new GUI engine. If you contact us via email we can give you a beta version so you can try it. There is also a beta version of PreView 2, but that one is still in early development stage. But if you like you can try it and see if it solves the problem.



06-01-2017 07:40 AM
Junior Member
Thanks for the advice
Both the rolled-back version and the current newest version of the Graphics driver (Nvidia GTX 1070) didn't work at first, but it is working fine now through some combination of:
- Not installing Nvidia HD Audio Driver
- Not installing Nvidia 3D Vision Driver
- Uninstalling GeForce experience

I have no interest in using any of these three things so I'm not going to go through and try to find out exactly which caused the problem but that should at least be somewhat helpful if anyone else is having a similar issue.


05-03-2018 03:25 PM
Lead Code Developer
Hi Liam,

As you may know we have recently released PreView 2.0. If you are still using PreView, can you let us know if you are still having issues?



+ Reply