Gravitational force does not work as it is supposed to

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
  • Yash9045
    Junior Member
    • Sep 2023
    • 8

    Gravitational force does not work as it is supposed to

    Hi, I was trying to run a simulation for women upper torso. I was able to do running basic analys giving prescribed deformation. But I have somethings to clarify after giving gravitation force.

    • I applied gravity load with this procedure

    • Physics -> Add body load -> Body force

    • hence I add the gravitation value.

    But after running the simulation. It show me not any deformation. maybe this could be due to the gravity force may not much impact on my model. For cases like this are there any options on FEBio to see more visible deformations?

    Since there is no any deformations I increase the gravitation force value and it show me small deformation. but the problem is the gravity load is not applying gradually as I observed in prescribed deformation. I have 10 steps for that simulation. only 1 step show the small deformation and remaining 9 steps have non deformed value. I just want to observe how my model look like when applying to gravity with smooth deformation when I play the button.

    I attached my model files with this. I would be really appreciated if you could clarify my doubts. Thank you!


  • maas
    Lead Code Developer
    • Nov 2007
    • 3573

    #2
    Hi Yash9045,

    If you don't have a load curve assigned to the body force, then the load will be applied in a single time step and the remaining steps will not show any additional deformation.
    To create a smooth deformation, you can assign a load curve to the body load as follows:
    - Open the Curve Editor (menu Tools \ Curve Editor or corresponding button on the toolbar).
    - In the left panel, locate and select the "force" parameter of the body force.
    - On the right panel, click the New... button at the top and select loadcurve.
    - Edit the load curve so that there are two points, one at (0,0) and the other at (1,1). (See here for some additional instructions on how to use the curve editor.)

    Please give this a try and let me know if that worked for you.

    Best,

    Steve
    Department of Bioengineering, University of Utah
    Scientific Computing and Imaging institute, University of Utah

    Comment

    • Yash9045
      Junior Member
      • Sep 2023
      • 8

      #3
      Originally posted by maas View Post
      Hi Yash9045,

      If you don't have a load curve assigned to the body force, then the load will be applied in a single time step and the remaining steps will not show any additional deformation.
      To create a smooth deformation, you can assign a load curve to the body load as follows:
      - Open the Curve Editor (menu Tools \ Curve Editor or corresponding button on the toolbar).
      - In the left panel, locate and select the "force" parameter of the body force.
      - On the right panel, click the New... button at the top and select loadcurve.
      - Edit the load curve so that there are two points, one at (0,0) and the other at (1,1). (See here for some additional instructions on how to use the curve editor.)

      Please give this a try and let me know if that worked for you.

      Best,

      Steve
      Thank you! It worked well.

      Comment

      Working...
      X