Problem with "Clone Revolve" in Geometry panel

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
  • jthiesen
    Junior Member
    • Nov 2022
    • 8

    Problem with "Clone Revolve" in Geometry panel

    Dear all, I hope you are doing well.

    I would like to point out that the Clone Revolve command on the Geometry panel does not work properly when entering decimal values for the angle, e.g. "90.5 degrees". I have tried using scientific notation for the input, like for some material properties input that only works that way, but it does not work either.

    Do you guys have any idea how to overcome this problem? Is it easy to fix this bug?

    Thank you very much.
    PhD Student at Federal University of Santa Catarina (UFSC, Brazil) and Research visitor at the Institute of Biomechanics (TU Graz)
  • maas
    Lead Code Developer
    • Nov 2007
    • 3369

    #2
    Hi jthiesen

    I'm afraid I cannot reproduce this. What version of FEBio Studio are you using? If it is not the latest version, (version 2.5) please update to the latest version and then give it another try. If you are on the latest version, please try updating to our development version (which is what I used to test this). Let us know what you find.

    Best,

    Steve
    Department of Bioengineering, University of Utah
    Scientific Computing and Imaging institute, University of Utah

    Comment

    • jthiesen
      Junior Member
      • Nov 2022
      • 8

      #3
      Dear Steve,

      I've tried to update FEBio to the development version and still can't reproduce this cloning correctly.

      I want to build a solid arc and apply a revolve clone with an angle range specified by a decimal number. When I use integers for the range, it works correctly.

      Thank you in advance,

      Josť.


      PhD Student at Federal University of Santa Catarina (UFSC, Brazil) and Research visitor at the Institute of Biomechanics (TU Graz)

      Comment

      • maas
        Lead Code Developer
        • Nov 2007
        • 3369

        #4
        Hi Josť,

        Thanks for trying that. I was hoping that would fix it.

        The other possibility is that your language setting does not use a period for a decimal point, but something else (e.g. a comma). I seem to recall we had some problems with that in the past, and I don't know if that has been fully resolved. I will look more into this. In the meantime, if your language setting indeed isn't set to English, then perhaps try changing it to English (if possible) and let me know if that solve the issue or not.

        Thanks,

        Steve
        Department of Bioengineering, University of Utah
        Scientific Computing and Imaging institute, University of Utah

        Comment

        • jthiesen
          Junior Member
          • Nov 2022
          • 8

          #5
          Hi Steve,

          I tried to change the default Windows language to English (FEBio was already set to English) and the problem persists.

          I also tried the same procedure on another PC with FEBio and found the same problem.

          Thank you in advance.

          Best wishes,
          Jose​​
          PhD Student at Federal University of Santa Catarina (UFSC, Brazil) and Research visitor at the Institute of Biomechanics (TU Graz)

          Comment

          • maas
            Lead Code Developer
            • Nov 2007
            • 3369

            #6
            Hi Josť,

            I apologize, I misunderstood your original post. I was able to reproduce the issue after all and I think I got it fixed. It had nothing to do with the language settings so make sure to reset those back to what they were before. Please do another development update and then give it another try. Let me know what you find.

            Best,

            Steve
            Department of Bioengineering, University of Utah
            Scientific Computing and Imaging institute, University of Utah

            Comment

            • jthiesen
              Junior Member
              • Nov 2022
              • 8

              #7
              Hi Steve.

              It works perfectly.

              Thanks for the prompt reply.

              Best regards

              Jose.
              PhD Student at Federal University of Santa Catarina (UFSC, Brazil) and Research visitor at the Institute of Biomechanics (TU Graz)

              Comment

              Working...
              X
              😀
              😂
              🥰
              😘
              🤢
              😎
              😞
              😡
              👍
              👎